Friday, June 19th, 2009
19
JUN
GTA IV PC Patch 1.0.4.0 released

Grand Theft Auto IV - General News | @ 09:38 AM MDT | By Ash_735
A new update for the PC version of Grand Theft Auto IV was released earlier today. It's a small "maintenance" release which brings the game to version 1.0.4.0. The only change noted by Rockstar in the release notes is "resource management adjustments based on the operating system detected".

To get the patch, simply log into Games for Windows Live from GTA IV or download it manually.
Viewer Comments
behzad_sol
Unregistered User

Registered: Jun 2008
Posts: 1,025
any other information for this one? I had many problems with all previous patches
06-19-2009 11:17 AM
ncl119
Registered User

Registered: May 2009
Posts: 2
Damn! its a complete Mod Breaker....
06-19-2009 11:47 AM
Ænemy
Digital/Concept Artist

Registered: Apr 2008
Posts: 236
I'll update some other time... when mods are brought up to that patch.
06-19-2009 12:30 PM
Nite
Addicted PC Gamer

Registered: Jul 2005
Posts: 4,893
I get the EFC20 error on this patch just like I did on 1.0.3.0, need to wait for someone to make a fix before I can use it.

Edit: Alex updated his topic, the EFC20 Fix is confirmed working on 1.0.4.0

http://www.gtaforums.com/index.php?showtopic=404170

[ post edited 06-20-2009 12:28 AM by Nite ]
06-20-2009 12:01 AM
/Acid/Rain
Registered User

Registered: Jun 2009
Posts: 0
R* announced a new large update?? Can anybody say, when it was and did they say, when it's coming?
06-20-2009 03:51 AM
behzad_sol
Unregistered User

Registered: Jun 2008
Posts: 1,025
@Nite: Yep, I just installed the patch, and the error poped up, thanks for the link too!
06-20-2009 03:53 AM
behzad_sol
Unregistered User

Registered: Jun 2008
Posts: 1,025
DAMN! I lost the internet cafe access again, R is a craziest company I've ever seen, dam...
06-20-2009 04:32 AM
Neil


Registered: Aug 2003
Posts: 3,610
I've noticed the game is using less system memory when I perform a benchmark but that isn't translating into significantly better framerates.
06-20-2009 05:22 AM
Nite
Addicted PC Gamer

Registered: Jul 2005
Posts: 4,893
Same here Neil, I had a 15% Reduction in memory usage but fps is still the same. The Game did have a memory leak in earlier patches so maybe thats all they fixed.
06-20-2009 06:46 AM
/Acid/Rain
Registered User

Registered: Jun 2009
Posts: 0
Do anybody know, did they announced any better support of single-core cpus?
I hate these lags and want better optimization for my 3.4 ghz..
06-20-2009 07:01 AM
Nite
Addicted PC Gamer

Registered: Jul 2005
Posts: 4,893
Not gonna happen Acid, the Game really needs a Quad Core chip (Intel Core 2 Quad / Core i7 or AMD Phenom 1 / 2) to run decent, even the dual core chips will struggle on it
06-20-2009 07:23 AM
thenotsogoodtrickster
late on the feels

Registered: Jun 2006
Posts: 870
Yeah, as Nite said, I have a 3.5GHz Core 2 Duo, and that has problems :/
06-21-2009 11:10 AM
rappo
Professional Dumbass


Registered: Aug 2003
Posts: 6,914
You don't need a Quad Core to make it run decently - I have a 2.4Ghz Intel Core 2 Duo and the game runs just fine
06-21-2009 05:51 PM
Jay
(V) (;,,;) (V)

Registered: Mar 2004
Posts: 6,402
This patch just broke my game. I wasn't surprised since every patch for GTA IV breaks more than it fixes.
07-10-2009 06:16 AM
 

Post Comment
Comments have been locked/disabled on this news post. 

Login to GTAGaming
Not a GTAGaming member yet?
Sign up now!

Username:
Password: 
Total Members: 177,960
8 Online, 1,087 Guests





Poll
Will you join the GTAGaming Crew and play GTA Online with us?

Yes, I am already in the GTAG crew. (31%)
Yes, I will join when GTA Online comes out. (28%)
No, I hate the GTAG crew. (19%)
Maybe, I have not fully decided. (13%)
No, I will play with a different crew. (8%)
Total Votes: 2,150
[ Hide | Poll Archive ]
Advertisement