Old 03-29-2009   #1
Lander
Registered User
 
Join Date: Mar 2009
Location: Chile
Posts: 31
Lander is on a distinguished roadLander is on a distinguished road
Problem with server

Hello everyone

I'm new on the forum, but not in the game.

Congratulations guys for build this client to play online one of my favourites games of all time. I know, I also play VC:MP and MTA, but this client is more flexible with the LUA script, this allow to make possible the impossible. And now, let's go to the problem.

I have the client and server, but when I host the server, this close without reason. In the server_log.txt doesn't say what's the error. This happend several times, when i put a command, when i shoot a player, etc.... I have the game in spanish language without mod (such ENBSeries, car mods, etc......)

I hope that you guys can fix this problem.

Thanks.

Last edited by Lander; 03-29-2009 at 08:33 PM..
Lander is offline   Reply With Quote
Old 03-29-2009   #2
ReGeX
VCO Developer
 
ReGeX's Avatar
 
Join Date: May 2008
Location: Florida, US
Posts: 52
ReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enough
Perhaps you could post your entire script?
__________________

.:: Visit Vice City Online's GTAGaming Page Today! ::.
ReGeX is offline   Reply With Quote
Old 03-29-2009   #3
Lander
Registered User
 
Join Date: Mar 2009
Location: Chile
Posts: 31
Lander is on a distinguished roadLander is on a distinguished road
Script???? I'm using the script that come with the server, without modifications. The Main.lua and the Extension_Vehicles.lua was hosted without modifications by me.
Lander is offline   Reply With Quote
Old 03-29-2009   #4
ReGeX
VCO Developer
 
ReGeX's Avatar
 
Join Date: May 2008
Location: Florida, US
Posts: 52
ReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enoughReGeX will become famous soon enough
There is no reason why your server would crash. Perhaps it's behind a firewall and still blocked?
__________________

.:: Visit Vice City Online's GTAGaming Page Today! ::.
ReGeX is offline   Reply With Quote
Old 03-29-2009   #5
Lander
Registered User
 
Join Date: Mar 2009
Location: Chile
Posts: 31
Lander is on a distinguished roadLander is on a distinguished road
I have opened the port 4800 UDP to play with a friend, and the server closed. Also I desactivated the windows firewall, and nothing.

I have the game in spanish language, my PC in the Spanish language too, with net frameworks required to play VCO
Lander is offline   Reply With Quote
Old 03-30-2009   #6
Mantis
Music=Life
 
Join Date: Mar 2009
Posts: 46
Mantis is on a distinguished roadMantis is on a distinguished roadMantis is on a distinguished roadMantis is on a distinguished road
I think I know what your problem is. I was experiencing it when I first hosted my test server. It seems like there is a bug in the script. I've done extensive tests on it, and I've been looking at car placements, I'm not too sure the cause 100% but I'm thinking it's got something to do with vehicles or a function/callback. I'll post with a fix when I manage to solve it.
Mantis is offline   Reply With Quote
Old 03-30-2009   #7
[LCK]G0LdzEr0
Registered User
 
Join Date: Mar 2009
Location: Poland, Częstochowa
Posts: 13
[LCK]G0LdzEr0 is an unknown quantity at this point
I have this same problem with server...
[LCK]G0LdzEr0 is offline   Reply With Quote
Old 03-30-2009   #8
Toiletduck
Registered User
 
Toiletduck's Avatar
 
Join Date: Mar 2009
Posts: 10
Toiletduck is an unknown quantity at this point
I solved this by removing all cars from my extension file.
I will write a new one soon but for now, it is working nicely.
Toiletduck is offline   Reply With Quote
Old 03-31-2009   #9
[LCK]G0LdzEr0
Registered User
 
Join Date: Mar 2009
Location: Poland, Częstochowa
Posts: 13
[LCK]G0LdzEr0 is an unknown quantity at this point
Code:
outputConsole("Creating vehicles and loading the extension...")
loadExtension("Extensions\\Extension_Vehicles.lua")
Bug is in this line (file: Main.lua). "\\" must be replaced by "/" and it will works fine
[LCK]G0LdzEr0 is offline   Reply With Quote
Old 03-31-2009   #10
Lander
Registered User
 
Join Date: Mar 2009
Location: Chile
Posts: 31
Lander is on a distinguished roadLander is on a distinguished road
Quote:
Originally Posted by [LCK]G0LdzEr0 View Post
Code:
outputConsole("Creating vehicles and loading the extension...")
loadExtension("Extensions\\Extension_Vehicles.lua")
Bug is in this line (file: Main.lua). "\\" must be replaced by "/" and it will works fine
I've changed that, but the problem persist. Maybe the problem is the extension_vehicles.lua
Lander is offline   Reply With Quote
Old 03-31-2009   #11
Raekwon
Registered User
Newbie Member
 
Join Date: Mar 2009
Posts: 5
Raekwon is an unknown quantity at this point
Hes having the same problem as me and I havnt gotten any replies, only difference is when it crashes on Linux it shows you why.

I think its obvious VC-O has serious memory allocation errors or needs to be compiled on other Linux distrobutions.


Edit: Fixed all of these issues with random crashing and memory allocation (glibc) errors on linux by only using loadExtension once.
everytime you use loadExtension() it gives every file the same ID and crashes the server at a random time.

Problem solved by switching to dofile() instead.

Last edited by Raekwon; 03-31-2009 at 09:22 PM..
Raekwon is offline   Reply With Quote
Old 03-31-2009   #12
Mantis
Music=Life
 
Join Date: Mar 2009
Posts: 46
Mantis is on a distinguished roadMantis is on a distinguished roadMantis is on a distinguished roadMantis is on a distinguished road
There is an issue with the default main.lua file that I've found, it's more of a code error, but still can cause server shutdown.
Using /stats works on yourself, but when you try to use /stats [id] it closes down the server.
I'm not saying this is the main cause, but that is a problem that can cause your error.
Mantis is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 05:46 AM.