GTAGaming Forums

GTAGaming Forums (http://www.gtagaming.com/forums/index.php)
-   Troubleshooting & Technology (http://www.gtagaming.com/forums/forumdisplay.php?f=303)
-   -   Corrupted save games (0 KB size) on modded game (http://www.gtagaming.com/forums/showthread.php?t=144046)

rootsrat 05-26-2014 06:04 AM

Corrupted save games (0 KB size) on modded game
 
Hey there. I am new to these forums and new to modding GTA - I have however experience in modding other games.

I have modded GTA IV accoring to a step by step guide, and my game looks and runs perfectly fine, however I am unable to save my games. The files are created, but they are 0KB in size and when I try to load a game, I get an error message. See screenshots below. Can anyone think why is that and how can I fix it? I will describe the modding process below, so that you know what mods I have used.

Also, the filenames in game look strange, not like vanilla game.

1. Nil-size save files:


2. In-game error message:


3. In-game file names:


The modding process:

1. Downgraded GTA IV to version 1.0.4.0
2. Changed the game directory name.
3. Installed Rockstar Social Tool, copied contents to the original game directory, deleted the new directory and changed the original directory name back to normal.
4. Downloaded GTAIV .Net Script Hook v1.7.1.7 BETA, copied dsound.dll, ScriptHook.dll and ScriptHookDotNet.asi to the game folder.
5. Created a shortcut to LaunchGTAIV.exe with -norestrictions argument and was running the game from this shortcut from now on.
6. Installed RealizmIV 6.2 and Fonts Mod
7. Installed Ultimate Textures 2.0
8. Installed VisualIV 1.7.6
9. Installed iCEnhancer 1.25

Like I said, my game runs fine, it looks great, I don't experience any glitches etc. Both auto save and manual saves however create empty files that cannot be loaded.

I would appreciate any help or advice! Thanks!

rootsrat 05-27-2014 01:10 PM

Has no one experienced this before?

Can anyone think of a solution to my problem?

I'm looking forward to solving this!

Killerfist 05-27-2014 02:23 PM

What exactly do you mean .. changed the game directory name? Of the my documents one or the program files one?

rootsrat 05-27-2014 03:04 PM

In the instruction in the guide I used it said, after downgrading the game to 1.0.4.0:

1) Download Rockstar Social Tool, but don't install it
2) Rename the game directory in Program Files
3) Install Rockstar Social Tool (it installs into Program Files with the same directory name as the original game, which is now in different - renamed - directory)
4) Copy the contents of installed Rockstar Social Tool into the renamed game directory
5) Delete the installed Rockstar Social Tool directory
6) Change the game's directory back to the original one

I guess it's to prevent RST overwriting the game folder when it's installed.

This is something to do with either my ASI loader or the ScriptHook that I use. I checked on vanilla install 1.0.7.0. copied dsound.dll, scripthook.dll and scripthookdontnet.asi into my gta folder and instanty my saved games stopped working. Any new saved games are 0 KB in size.

Exactly same thing happened when I downgraded to 1.0.4.0.

Any thoughts, advice, help?

Killerfist 05-28-2014 06:59 AM

it's an odd problem, never heard of it happening before .. you could try an alternative asi loader (xliveless for instance, but that'll change the directory of the savegames)

I believe there's another asi loader but can't recall the name

You're sure you're using all the right files ? There are different versions of those files for different versions of gta

rootsrat 05-28-2014 09:55 AM

Yeah, I was only looking it into more detail yesterday. At first I've only followed the guide... Think I'll solve this eventually. Thanks for your input though. I think I'm moving in the right direction now. Shall I need any help, I'll come back here :)

Thanks again.


All times are GMT -6. The time now is 10:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.