GTAGaming Forums

GTAGaming Forums (http://www.gtagaming.com/forums/index.php)
-   Grand Theft Auto IV Mods (http://www.gtagaming.com/forums/forumdisplay.php?f=318)
-   -   Scripthook scripts not functioning correctly! (http://www.gtagaming.com/forums/showthread.php?t=141194)

kugotsumin 05-06-2013 03:43 PM

Scripthook scripts not functioning correctly!
 
First let me tell you what i have installed, I have GTA IV 1.0.4.0. With ICenhancer 2.1 fxaa on. I also have some hd road mod, and finally Ultimate Vehicle Pack V10 by zz cool. A few things that don't seem to work correctly, would be for example the EPM mod with more realistic injuries during crashes, you're supposed to be able to put your seatbelt on with left alt, it does not. Then there's light indicator mod where you're supposed to have working signal lights with Q and E, this does not work at all. I have also tried having the vehicle pack itself installed, but only taxis appear. I know the solution to this is trafficflow, but this killed my texture loading performance, so I simply can't have the vehicle pack installed. Also I'm using scripthook.dll 0.4.0 and asiloader 1020b. Anyway, would appreciate your advice, if any more info would help please ask me for it.

Killerfist 05-06-2013 05:27 PM

I've never heard of 'asiloader 1020b' try using dsound.dll and throw that one (1020b) away

Not sure which version of scripthook.dll is the correct one for your patch but I'm assuming you checked

kugotsumin 05-06-2013 05:30 PM

i dunno it comes as asi loader 1020b, and in the archive is dsound. Also, i assumed 0.4.0 is the right scripthook for 1.0.4.0 because it doesn't crash when loading my game, 0.5.1 does.

is it that no one knows how to solves this problem? Or that everybody who does doesn't care?

if someone doesn't offer some crucial advice soon i may begin to swear.

Killerfist 05-07-2013 09:08 AM

There aren't alot of people active on this (section of the) forum anymore, be patient.

I can't imagine scripthook causing the problem so delete any asiloader you have (xliveless, dsound, alexander blade or w/e) and redownload it from this link:

http://www.fileplanet.com/221332/220...V---ASI-Loader

If that still doesn't work check to see if you got all scripthook files (scripthook.dll, ScriptHookDotNet.asi and both corresponding text files).

Last option would be just updating to the latest patch and downloading this:
http://www.mediafire.com/?mkd87cns1jr85cu

It's my set of files I use which are guaranteed to work (on patch 1.0.7.0)

kugotsumin 05-07-2013 11:04 AM

i downloaded your thing and put sripthookdotnet.asi in my folder and it's all good now. Thanks. but now when i press left alt to put on my seatbelt, i'm spawning a turismo or super gt :/ everything else is good though

Killerfist 05-09-2013 05:40 AM

Oh that's because of the trainer files, if you don't want simple native trainer just delete those trainer.ini and trainer.asi files. If you do want to keep it you could open up trainer.ini and scroll down to 'KeyBindingsDisabled' and put that on 1 instead of 0.

Simple native trainer has alot of keybinding, because of conflicting keys I usually keep that on disabled so you only access the functions of the trainer through the menu (F3).

ing598776@yahoo 05-18-2013 10:16 AM

OpenIV 1.4 要怎麼在遊戲內開啟
 
我安裝的OpenIV 1.4
我都改好了但是進入遊戲都不能開
我是GTA4正版光碟
有人能幫幫我教我怎麼才能把我改的車或是其他的都叫出來


All times are GMT -6. The time now is 11:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.