GTAGaming Forums

GTAGaming Forums (http://www.gtagaming.com/forums/index.php)
-   Grand Theft Auto IV Mods (http://www.gtagaming.com/forums/forumdisplay.php?f=318)
-   -   Script Mods problem (EFLC) (http://www.gtagaming.com/forums/showthread.php?t=136027)

Homyans 12-10-2012 11:06 AM

Script Mods problem (IV And EFLC)
 
So I installed EFLC Yesterday I Was playing on my old PC but after the upgrade to the components of my PC That happened 3 months ago, But yesterday I Said I Shall install EFLC And now I installed it the script mods are working but after I Save the game and quit and come back the Scripts don't work, They work when I Don't save but you Know it's impossible to play a game without saving!
Please anyone know a fix please help thanks. :)

EDIT: I Found out that this also happens to me on IV. It was a long time I Wasn't saving but what the hell anyone know a fix please tell me please.

Naruto 607 12-24-2012 06:18 AM

Quote:

Originally Posted by Homyans (Post 2280474)
So I installed EFLC Yesterday I Was playing on my old PC but after the upgrade to the components of my PC That happened 3 months ago, But yesterday I Said I Shall install EFLC And now I installed it the script mods are working but after I Save the game and quit and come back the Scripts don't work, They work when I Don't save but you Know it's impossible to play a game without saving!
Please anyone know a fix please help thanks. :)

My friend, I'm not an expert programmer, but just to make sure, what version of EFLC you are using?
I'm having issues that I can't play GTA IV, either EFLC when I upgraded my OS to Windows 7 Ultimate 64-bit (that's real pathetic long time ago before I found this website and before I upgraded my VGA Card, not sure for the next testing), so I stick myself to Windows XP SP2 64-bit.

My recommendation is to use latest Scripthookdotnet (v1.7.1.7 Beta is out there, currently) when your EFLC is upgraded to 1.1.1.0 or 1.1.2.0 (which in 1.1.2.0, you can play LCPDFR) with the latest Scripthook version (v5.1.0 is the latest, currently, which you can find it in Simple Native Trainer on gta4-mods.com) and an ASI loader (I use Alexander Blade's ASI Loader).

Mine's running in EFLC v1.1.1.0 with a little script mods (like Equip Gun, WatchCats, etc.) and a SNT, but everything seems to be no trouble. When loading saved games with scripts like that, it's still working. Just the thing that the Equip Gun script sometimes error.

If my recommendation is met, see if you can get your desired scripts working in the game. If not, hit the "~" (tilde) button on the keyboard. You should see the green console on top of the screen. After that, type "reloadscripts" and hit Enter. Wait until it completely reloads, then check again if your desired scripts work for the second time.

I'm afraid I cannot help much further if:
- when the tilde button pressed, green console didn't appear (reload your save game is a momentarily solution)
- after it reloaded many times, it's a no go (meaning always get error at ALL times), and
- your EFLC version is not at 1.1.1.0 or 1.1.2.0.

I look forward to this if my suggestion helps. Cheers, my friend. :)

Homyans 12-24-2012 09:41 AM

Thanks for your Reply bro Yes this problem happened to me when I Switched to Windows 7 (Was XP SP3) Also found out that It's not a savegame problem sometimes it works sometimes it doesn't, Yeah I Tried ReloadScripts before but the console doesn't open and my EFLC Is 1.1.2.0

Naruto 607 12-25-2012 08:05 AM

Quote:

Originally Posted by Homyans (Post 2282706)
Thanks for your Reply bro Yes this problem happened to me when I Switched to Windows 7 (Was XP SP3) Also found out that It's not a savegame problem sometimes it works sometimes it doesn't, Yeah I Tried ReloadScripts before but the console doesn't open and my EFLC Is 1.1.2.0

Hmm... that's weird. How many scripts did you installed and what are they? Did you installed other mods to EFLC other than scripts? Did the SNT working when the scripts not working? And did you try to reload your savegame when trying to open or access the console?

My guessing is to check one-by-one the scripts which may improperly work on EFLC. If there's one which is not working, tell me.

I'm having a minimal help to you because I'm having a vacation at Bali with my family. If I were at home, I would help you much further.

Cheers, my friend.:)

Homyans 01-03-2013 11:49 AM

These scripts were working on my other PC. And something weird I found that this problem is happening to me on IV Too.

Killerfist 01-03-2013 01:35 PM

Which scriptmods are you using?

Naruto 607 01-03-2013 09:09 PM

Quote:

Originally Posted by Homyans (Post 2283958)
These scripts were working on my other PC. And something weird I found that this problem is happening to me on IV Too.

Bro, WTF? On your IV too? :confused: I never know that it happened on your GTA IV. I would suggest to remove Scripthookdotnet.asi file from your computer for a while and see if it works (just make sure that you have the backup if you want to restore it).

Homyans 01-03-2013 11:52 PM

@Killerfist:
1-SNT 6.4
2-First Person
3-Gestures Mod
.Net Scripts:
1-AC130
2-Dart
3.Dead Eye
4.FusRoDah
5.Knife
6.Piss
7.Slowmotion
@Naruto: Actually I Figured this out yesterday that it isn't working on my IV Too. I Removed Scripthookdotnet.asi but no use.

Killerfist 01-04-2013 04:08 AM

You could try moving them (temporarily) to a different folder, and just leaving simple native trainer (along with scripthook, and an asiloader). If that works move a couple back and see if the game still works

Might just be a few conflicting scripts since you have so many installed

Homyans 01-04-2013 10:38 AM

I Tried it It still didn't work. I Removed all of the scripts, saved the game and exited and installed SNT With Scripthook and asiloader still didn't work.
Edit: I loaded an old save in the same game session the the trainer wasn't working.
After loading the old savegame it worked I Mean there is a problem with the savegame.
Edit Again: After starting a new game it starts to work but when I Load old savegame it doesn't work.

Homyans 01-08-2013 03:24 AM

Please Someone help me please!

Naruto 607 01-18-2013 10:03 PM

Quote:

Originally Posted by Homyans (Post 2284545)
Please Someone help me please!

I think your computer has a connection with your OS or some kind. I'm running Windows XP SP2 64-bit with metalwars' script mods, and any other ASI Scripts like SNT, but so far I have no problems with that.

Try reinstall the game and make backup of your savegames. ...Just hold on, is this problem occur when you're the first time using IV and EFLC? :confused: I don't know really about it...

Homyans 01-19-2013 04:38 AM

Actually thanks for the reply But I solved it anyone want to know how just ask.

Killerfist 01-19-2013 04:27 PM

I am curious what the problem was exactly, so do tell (might also be useful for any people searching the forums with similar problems).

Homyans 01-20-2013 04:20 AM

Man It's just weird, I Started a new game in EFLC (TBOGT) And played the game and saved, then I Did a clean save with no scripts, Loaded my finished save game, Removed DeadEye script and added all of the other scripts. and now it works, by saying weird I mean you said there could be conflict but IDK this time it worked in TBOGT Didn't try it on IV or TLAD But I Guess TLAD Will work.


All times are GMT -6. The time now is 01:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.