GTAGaming Forums

GTAGaming Forums (http://www.gtagaming.com/forums/index.php)
-   Troubleshooting & Technology (http://www.gtagaming.com/forums/forumdisplay.php?f=303)
-   -   Mods Not Working (http://www.gtagaming.com/forums/showthread.php?t=132683)

Starwind Amada 05-14-2012 11:47 AM

Mods Not Working
 
It seems that no matter what I do, I cannot get any mods to work in GTA IV. The game runs fine, but no matter what I do, the game doesn't change, or something goes wrong. For example, I tried installing the World Trade Center mod. Followed the instructions to the letter. Nothing. Not WTC in sight. Tried programs like OpenIV and SparkIV. Neither changes a thing. Tried altering the weaponsinfo.xml file to mess with the weapons. Instead it disabled all weapons and melee (for myself and the NPCs). This is why GTA V needs to have Steam Workshop support.

Also, half the time I can't install something because the instructions are wrong or are in another language, if there are any at all. Why is it that people seem to lose their grasp of the English language when writing instructions? Here's an example from one mod I saw:

To install this stuff, just go to the one directory where you put GTA IV (find it yourself LOL) and put the files I made in there. But back up your files or you will lose everything, which is your fault lol. After you change the parameters in the weapons (easy to figure out, I don't want to explain) you should be all good. If you have any questions, e-mail me at (removed).

See, he doesn't explain a thing, uses Internet lingo and admits to not giving a crap and gives out an email address that doesn't work (I tried it). Looks like GTA IV modding is a bust for me. Time to go back to Skyrim.

Killerfist 05-15-2012 01:34 PM

The description you gave of a readme is indeed a pain in the ass for players that just started adding mods to their game. I try to keep my readme's as clear as possible and in decent english. It's just that there are alot of non-english modders so you can't expect them to write in perfect english. I'm Dutch myself so my english isn't perfect either .

As for the mods not working, when using SparkIV did you hit 'Save' after you've imported the modded files? Have you also updated your game to 1.0.4.0. or 1.0.7.0.? Most mods are made for that first patch but mostely work for the latest patch too.

The easiest mod to try out is a weaponsmod, if you'd like I can explain in detail how to install one. Let's take one of my own for example (that way I know for sure that it works and it's not the mod that's non-functional) Just leave the sound alone for now and only install the weapon itself:

http://www.gta4-mods.com/weapons/des...ngraved-f12979

Now open up SparkIV and hit Browse, go the pc/models/cdimages and double click weapons.img. Hit the big 'import button' and select both the .wdr and the .wtd file that's in that package. When you've done it correctly the should be highlighted in blue, hit save if this is the case. Now just exit SparkIV and fire up your game. You can now just try out if it works, if you haven't got a desert eagle in game just use the cheat for it (dial 486 555 0100)

If it still doesn't work, do you have a backup of your game and is it possible SparkIV navigates to that one? If you want to know for sure that you have the right weapons.img just go the your gta 4 folder and go the pc/models/cdimages and right-click weapons.img and select open with .. and select SparkIV (probably not yet in the programs list so just browse to it).

Don't give up too quick, gta 4 can be alot of fun with mods


All times are GMT -6. The time now is 01:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.